Search NASA⌕ Search

SEARCH · Search NASA

Results for “cyclic error”

Search indexed NASA NTRS and DOE OSTI research on propulsion, heat transfer, battery materials and energy systems. Follow report and document links to the original sources.

Quote a phrase for an exact phrase match. Source license links do not imply unrestricted reuse.

At least 91 records · Page 5

Forced response of mistuned bladed disks

Small mistuning can cause large, catastrophic changes in blade vibrational response whereby the amplitudes of vibration of some blades may increase by several hundred percent. This can produce 'rogue' blades and HCF failure. The free and forced responses may be highly sensitive to mistuning, and the tuned system predictions may be qualitatively in error and grossly underestimate blade forced response and overestimate fatigue life. Manufacturing tolerances, material non-uniformities, nonidentical root fixtures, and in-service degradation result in blade-to-blade differences that destroy cyclic symmetry in bladed discs. Therefore, a credible forced response prediction system for turbomachinery vibration must take mistuning into account. This report addresses these problems, states several objectives, and introduces NASA research program thrusts concerning this problem. This report was given during the NASA LeRC Workshop on Forced Response in Turbomachinery in August of 1993.

Pierre, Christophe↗

Optimum Cyclic Redundancy Codes for Noisier Channels

Binary cyclic redundancy codes for feedback communication over noisy digital links are considered. The standard 16 bit American Data and Computer Communication Protocol (ADCCP) polynomial is designed for digital links which already have a low input bit error probability. For file transfer between personal computers over telephone circuits, the quality of resulting digital circuit may be much lower. The 3 byte (24 bit) and 4 byte (32 bit) polynomials are considered. Generator polynomials of a certain class have minimum weight and yet achieve the bound on minimum distance for arbitrary codes. Particular choices for 24 bit and 32 bit redundancies are exhibited: of weight and distance 6 in the 24-bit case; and weight 10 and distance 8 in the 32-bit case.

Merkey, P.↗

Optimum cyclic redundancy codes for noisy channels

Binary cyclic redundancy codes for feedback communication over noisy digital links are considered. The standard 16 bit American Data and Computer Communication Protocol (ADCCP) polynomial is designed for digital links which already have a low input bit error probability. For file transfer between personal computers over telephone circuits, the quality of resulting digital circuit may be much lower. The 3 byte (24 bit) and 4 byte (32 bit) polynomials are considered. Generator polynomials of a certain class have minimum weight and yet achieve the bound on minimum distance for arbitrary codes. Particular choices for 24 bit and 32 bit redundancies are exhibited: of weight and distance 6 in the 24-bit case; and weight 10 and distance 8 in the 32-bit case.

Merkey, P.↗

Sensitivity of acoustic predictions to variation of input parameters

Rotor noise prediction codes predict the thickness and loading noise produced by a helicopter rotor, given the blade motion, rotor operating conditions, and fluctuating force distribution over the blade surface. However, the criticality of these various inputs, and their respective effects on the predicted acoustic field, have never been fully addressed. This paper examines the importance of these inputs, and the sensitivity of the acoustic predicitions to a variation of each parameter. The effects of collective and cyclic pitch, as well as coning and cyclic flapping, are presented. Blade loading inputs are examined to determine the necessary spatial and temporal resolution, as well as the importance of the chordwise distribution. The acoustic predictions show regions in the acoustic field where significant errors occur when simplified blade motions or blade loadings are used. An assessment of the variation in the predicted acoustic field is balanced by a consideration of Central Processing Unit (CPU) time necessary for the various approximations.

Brentner, Kenneth S.↗

ALMA Observations of α Centauri First Detection of Main-Sequence Stars at 3 mm Wavelength

The precise mechanisms that provide the non-radiative energy for heating the chromosphere and the corona of the Sun and those of other stars constitute an active field of research. By studying stellar chromospheres one aims at identifying the relevant physical processes. Defining the permittable extent of the parameter space can also serve as a template for the Sun-as-a-star. This feedback will probably also help identify stars that potentially host planetary systems that are reminiscent of our own. Earlier observations with Herschel and APEX have revealed the temperature minimum of Alpha Cen, but these were unable to spatially resolve the binary into individual components. With the data reported in this Letter, we aim at remedying this shortcoming. Furthermore, these earlier data were limited to the wavelength region between 100 and 870 um. In the present context, we intend to extend the spectral mapping (SED) to longer wavelengths, where the contrast between stellar photospheric and chromospheric emission becomes increasingly evident. The Atacama Large Millimeter submillimeter Array (ALMA) is particularly suited to point sources, such as unresolved stars. ALMA provides the means to achieve our objectives with both its high sensitivity of the collecting area for the detection of weak signals and the high spatial resolving power of its adaptable interferometer for imaging close multiple stars. This is the first detection of main-sequence stars at a wavelength of 3 mm. Furthermore, the individual components of the binary Alpha CenAB are clearly detected and spatially well resolved at all ALMA wavelengths. The high signal-to-noise ratios of these data permit accurate determination of their relative flux ratios, i.e., S(sub y(sup B)) / S(sub y(sup A))> = 0.54 +/- 0.04 at 440 μm, = 0.46 +/- 0.01 at 870 μm, and = 0.47 +/- 0.006 at 3.1 mm, respectively.. The previously obtained flux ratio of 0.44+/-0.18, which was based on measurements in the optical and at 70 μm, is consistent with the present ALMA results, albeit with a large error bar. The observed 3.1 mm emission greatly exceeds what is predicted from the stellar photospheres, and undoubtedly arises predominantly as free-free emission in the ionized chromospheric plasmas of both stars. Given the distinct difference in their cyclic activity, the similarity of their submm SEDs appears surprising.

Herschel↗

Multiple feedback control apparatus for power conditioning equipment

An improved feedback control system to govern the cyclic operation of the power switch of a non-dissipative power conditioning equipment. The apparatus includes two or three control loops working in unison. The first causes the output DC level to be compared with a reference, and the error amplified for control purposes. The second utilizes the AC component of the voltage across the output filter inductor or the current through the output filter capacitor, and the third loop senses the output transients.

Biess, John↗

Sensitivity of acoustic predictions to variation of input parameters

The noise prediction code WOPWOP predicts the thickness and loading noise produced by a helicopter rotor, given the blade motion, rotor operating conditions, and fluctuating force distribution over the blade surface. However, the criticality of these various inputs, and their respective effects on the predicted acoustic field, have never been fully addressed. This paper examines the importance of these inputs, and the sensitivity of the acoustic predictions to a variation of each parameter. The effects of collective and cyclic pitch, as well as coning and flapping, are presented. Blade loading inputs are examined to determine the necessary spatial and temporal resolution, as well as the importance of the cordwise distribution. The acoustic predictions show regions in the acoustic field where significant errors occur when simplified blade motions or blade loadings are used. An assessment of the variation in the predicted acoustic field is balanced by a consideration of CPU time necessary for the various approximations.

Brentner, Kenneth S.↗

Trends in MODIS Geolocation Error Analysis

Data from the two MODIS instruments have been accurately geolocated (Earth located) to enable retrieval of global geophysical parameters. The authors describe the approach used to geolocate with sub-pixel accuracy over nine years of data from M0DIS on NASA's E0S Terra spacecraft and seven years of data from MODIS on the Aqua spacecraft. The approach uses a geometric model of the MODIS instruments, accurate navigation (orbit and attitude) data and an accurate Earth terrain model to compute the location of each MODIS pixel. The error analysis approach automatically matches MODIS imagery with a global set of over 1,000 ground control points from the finer-resolution Landsat satellite to measure static biases and trends in the MO0lS geometric model parameters. Both within orbit and yearly thermally induced cyclic variations in the pointing have been found as well as a general long-term trend.

Wolfe, R. E.↗

Identification of state variables and dynamic inflow from rotor model dynamic tests

The paper describes methods for extracting unknown state variables and parameters from dynamic rotor model tests given transient cyclic pitch stirring inputs, blade root flap-bending measurements, and the form of the dynamic rotor equations, including a rotor dynamic inflow description, when none of the physical parameters are known. A simplified version of the maximum likelihood method seems best suited for this purpose. The measurement equation error covariance matrix is assumed constant during each iteration, but updated for the subsequent iteration. A detailed analysis of the suitability of the derived techniques for studying various rotor dynamic inflow effects is provided.

Banerjee, D.↗

Robust Damage-Mitigating Control of Aircraft for High Performance and Structural Durability

This paper presents the concept and a design methodology for robust damage-mitigating control (DMC) of aircraft. The goal of DMC is to simultaneously achieve high performance and structural durability. The controller design procedure involves consideration of damage at critical points of the structure, as well as the performance requirements of the aircraft. An aeroelastic model of the wings has been formulated and is incorporated into a nonlinear rigid-body model of aircraft flight-dynamics. Robust damage-mitigating controllers are then designed using the H(infinity)-based structured singular value (mu) synthesis method based on a linearized model of the aircraft. In addition to penalizing the error between the ideal performance and the actual performance of the aircraft, frequency-dependent weights are placed on the strain amplitude at the root of each wing. Using each controller in turn, the control system is put through an identical sequence of maneuvers, and the resulting (varying amplitude cyclic) stress profiles are analyzed using a fatigue crack growth model that incorporates the effects of stress overload. Comparisons are made to determine the impact of different weights on the resulting fatigue crack damage in the wings. The results of simulation experiments show significant savings in fatigue life of the wings while retaining the dynamic performance of the aircraft.

Caplin, Jeffrey↗

Active control of tiltrotor blade in-plane loads during maneuvers

The origin of one/rev rotor aerodynamic loads which arise in tiltrotor aircraft during airplane-mode high speed pull-up and push-over maneuvers is examined using a coupled rotor/fuselage dynamic simulation. A modified eigenstructure assignment technique is used to design a controller which alleviates the in-plane loads during high pitch rate maneuvers. The controller utilizes rotor cyclic pitch inputs to restructure the aircraft short period and phugoid responses in order to achieve the coupling between pitch rate and rotor flapping responses which minimizes the rotor aerodynamic loading. Realistic time delays in the feedback path are considered during the controller design. Stability robustness in the presence of high frequency modeling errors is ensured through the use of singular value analysis.

Miller, David G.↗

Totally parallel multilevel algorithms

Four totally parallel algorithms for the solution of a sparse linear system have common characteristics which become quite apparent when they are implemented on a highly parallel hypercube such as the CM2. These four algorithms are Parallel Superconvergent Multigrid (PSMG) of Frederickson and McBryan, Robust Multigrid (RMG) of Hackbusch, the FFT based Spectral Algorithm, and Parallel Cyclic Reduction. In fact, all four can be formulated as particular cases of the same totally parallel multilevel algorithm, which are referred to as TPMA. In certain cases the spectral radius of TPMA is zero, and it is recognized to be a direct algorithm. In many other cases the spectral radius, although not zero, is small enough that a single iteration per timestep keeps the local error within the required tolerance.

Frederickson, Paul O.↗

The Influence of Unsteadiness on the Analysis of Pressure Gain Combustion Devices

Pressure gain combustion (PGC) has been the object of scientific study for over a century due to its promise of improved thermodynamic efficiency. In many recent application concepts PGC is utilized as a component in an otherwise continuous, normally steady flow system, such as a gas turbine or ram jet engine. However, PGC is inherently unsteady. Failure to account for the effects of this periodic unsteadiness can lead to misunderstanding and errors in performance calculations. This paper seeks to provide some clarity by presenting a consistent method of thermodynamic cycle analysis for a device utilizing PGC technology. The incorporation of the unsteady PGC process into the conservation equations for a continuous flow device is presented. Most importantly, the appropriate method for computing the conservation of momentum is presented. It will be shown that proper, consistent analysis of cyclic conservation principles produces representative performance predictions.

Paxson, Daniel E.↗

Error control techniques for satellite and space communications

Worked performed during the reporting period is summarized. Construction of robustly good trellis codes for use with sequential decoding was developed. The robustly good trellis codes provide a much better trade off between free distance and distance profile. The unequal error protection capabilities of convolutional codes was studied. The problem of finding good large constraint length, low rate convolutional codes for deep space applications is investigated. A formula for computing the free distance of 1/n convolutional codes was discovered. Double memory (DM) codes, codes with two memory units per unit bit position, were studied; a search for optimal DM codes is being conducted. An algorithm for constructing convolutional codes from a given quasi-cyclic code was developed. Papers based on the above work are included in the appendix.

Costello, Daniel J., Jr.↗

Atmospheric Ascent Guidance for Rocket-Powered Launch Vehicles

An advanced ascent guidance algorithm for rocket- powered launch vehicles is developed. This algorithm cyclically solves the calculus-of-variations two-point boundary-value problem starting at vertical rise completion through main engine cutoff. This is different from traditional ascent guidance algorithms which operate in a simple open-loop mode until high dynamic pressure (including the critical max-Q) portion of the trajectory is over, at which time guidance operates under the assumption of negligible aerodynamic acceleration (i.e., vacuum dynamics). The initial costate guess is corrected based on errors in the terminal state constraints and the transversality conditions. Judicious approximations are made to reduce the order and complexity of the state/costate system. Results comparing guided launch vehicle trajectories with POST open-loop trajectories are given verifying the basic formulation of the algorithm. Multiple shooting is shown to be a very effective numerical technique for this application. In particular, just one intermediate shooting point, in addition to the initial shooting point, is sufficient to significantly reduce sensitivity to the guessed initial costates. Simulation results from a high-fidelity trajectory simulation are given for the case of launch to sub-orbital cutoff conditions as well as launch to orbit conditions. An abort to downrange landing site formulation of the algorithm is presented.

Dukeman, Greg A.↗

Major episodes of geologic change - Correlations, time structure and possible causes

Published data sets of major geologic events of the past about 250 Myr (extinction events, sea-level lows, continental flood-basalt eruptions, mountain-building events, abrupt changes in sea-floor spreading, ocean-anoxic and blackshale events and the largest evaporite deposits) have been synthesized (with estimated errors). These events show evidence for a statistically significant periodic component with an underlying periodicity, formally equal to 26.6 Myr, and a recent maximum, close to the present time. The cycle may not be strictly periodic, but a periodicity of about 30 Myr is robust to probable errors in dating of the geologic events. The intervals of geologic change seem to involve jumps in sea-floor spreading associated with episodic continental rifting, volcanism, enhanced orogeny, global sea-level changes and fluctuations in climate. The period may represent a purely internal earth-pulsation, but evidence of planetesimal impacts at several extinction boundaries, and a possible underlying cycle of 28-36 Myr in crater ages, suggests that highly energetic impacts may be affecting global tectonics. A cyclic increase in the flux of planetesimals might result from the passage of the Solar System through the central plane of the Milky Way Galaxy - an event with a periodicity and mean phasing similar to that detected in the geologic changes.

Rampino, Michael R.↗

Survey of Header Compression Techniques

This report provides a summary of several different header compression techniques. The different techniques included are: (1) Van Jacobson's header compression (RFC 1144); (2) SCPS (Space Communications Protocol Standards) header compression (SCPS-TP, SCPS-NP); (3) Robust header compression (ROHC); and (4) The header compression techniques in RFC2507 and RFC2508. The methodology for compression and error correction for these schemes are described in the remainder of this document. All of the header compression schemes support compression over simplex links, provided that the end receiver has some means of sending data back to the sender. However, if that return path does not exist, then neither Van Jacobson's nor SCPS can be used, since both rely on TCP (Transmission Control Protocol). In addition, under link conditions of low delay and low error, all of the schemes perform as expected. However, based on the methodology of the schemes, each scheme is likely to behave differently as conditions degrade. Van Jacobson's header compression relies heavily on the TCP retransmission timer and would suffer an increase in loss propagation should the link possess a high delay and/or bit error rate (BER). The SCPS header compression scheme protects against high delay environments by avoiding delta encoding between packets. Thus, loss propagation is avoided. However, SCPS is still affected by an increased BER (bit-error-rate) since the lack of delta encoding results in larger header sizes. Next, the schemes found in RFC2507 and RFC2508 perform well for non-TCP connections in poor conditions. RFC2507 performance with TCP connections is improved by various techniques over Van Jacobson's, but still suffers a performance hit with poor link properties. Also, RFC2507 offers the ability to send TCP data without delta encoding, similar to what SCPS offers. ROHC is similar to the previous two schemes, but adds additional CRCs (cyclic redundancy check) into headers and improves compression schemes which provide better tolerances in conditions with a high BER.

Ishac, Joseph↗

Near-infrared spectroscopy for monitoring of tissue oxygenation of exercising skeletal muscle in a chronic compartment syndrome model

Variations in the levels of muscle hemoglobin and of myoglobin oxygen saturation can be detected non-invasively with near-infrared spectroscopy. This technique could be applied to the diagnosis of chronic compartment syndrome, in which invasive testing has shown increased intramuscular pressure associated with ischemia and pain during exercise. We simulated chronic compartment syndrome in ten healthy subjects (seven men and three women) by applying external compression, through a wide inflatable cuff, to increase the intramuscular pressure in the anterior compartment of the leg. The tissue oxygenation of the tibialis anterior muscle was measured with near-infrared spectroscopy during gradual inflation of the cuff to a pressure of forty millimeters of mercury (5.33 kilopascals) during fourteen minutes of cyclic isokinetic dorsiflexion and plantar flexion of the ankle. The subjects exercised with and without external compression. The data on tissue oxygenation for each subject then were normalized to a scale of 100 per cent (the baseline value, or the value at rest) to 0 per cent (the physiological minimum, or the level of oxygenation achieved by exercise to exhaustion during arterial occlusion of the lower extremity). With external compression, tissue oxygenation declined at a rate of 1.4 +/- 0.3 per cent per minute (mean and standard error) during exercise. After an initial decrease at the onset, tissue oxygenation did not decline during exercise without compression. The recovery of tissue oxygenation after exercise was twice as slow with compression (2.5 +/- 0.6 minutes) than it was without the use of compression (1.3 +/- 0.2 minutes).

NASA Discipline Musculoskeletal↗